9,971 views

Finally have some time again

Finally found some time again to work on the Exchange add-on. Fixed some of the big outstanding problems due to changes in Exchange and Thunderbird.

Please try latest beta 3.2.0-beta48.

This entry was posted in Geen categorie. Bookmark the permalink.

13 Responses to Finally have some time again

  1. Timo Kunze says:

    Thanks for the update, but it seems to have a problem with Exchange 2007 SP3. In the logs I can see these lines:

    sendRequest Sending:
    AllPropertiestkunze@compeso.com

    and later:

    ExchangeRequest.onLoad :soap:Senderq0:ErrorInvalidServerVersionDie angegebene Serverversion ist ungültig.ErrorInvalidServerVersionDie angegebene Serverversion ist ungültig.
    exchangeRequest.isHTTPRedirect.xmlReq. xmlReq.readyState:4, xmlReq.status:500
    ErrorInvalidServerVersion -> RequestServerVersion wrong:Exchange2007_SP3.

    Beta 46 has been working without problems.

    Regards
    Timo

  2. Timo Kunze says:

    Damn, WordPress ate the XML in my comment. Well, the problem seems to be that the request is done with RequestServerVersion Version=”Exchange2007_SP3″ and the Exchange Server rejects it.

  3. david mace says:

    thanks dude

  4. Daniel Castro says:

    This is great news! Thank you very much for sucha great addon. I’ve been using 3.1.3 because I find it’s the more stable and less resource consuming. The 3.2.0 betas seem to have big CPU spikes and makes my TB very slow. Please let me know if I can help with any testing or logs or whatever.

  5. Tobias says:

    Hey,

    Great that you’ve got some time to work on this again.
    I just can’t make it work with Thunderbird 24.0.1 and Lightning 2.6.1 with the same Exchange that worked like a charm before.
    There were some reported issues to a major change in Lightning. Are you aware of this?

    Thanks a lot for this great plugin!
    Tobi

  6. Cas says:

    Great work, thank you so much for your continuing effort!

  7. Dan W. says:

    Even with beta51, I’m still having problems with jobs hanging. The status bar has said “1 running & 3 queued jobs” for the last few hours now. Is there some way to know what is hung up, and why?

  8. Ansgar says:

    The Exchange plugin stopped working some time ago (probably with the update to thunderbird 24). Currently, I cannot create a new calendar any more, neither with the beta53 nor the old 3.1.3 version. In both cases, “check server and mailbox” just hangs sforever. The https server address seems to be ok, since I get a response when I use this address in the web-browser.
    The log ends with
    1st-setup: exchWebServicesConvertIDOK: user:intra\xxx, mailbox:xxx
    (U replaced real addresses by xxx)

  9. Ansgar says:

    Thanks a lot! it now works fine. However, it seems that the culprit was not the beta53, but thunderbird or the lightning calendar (I had an automatic upgrate to 24.1.0 (from 24.0) and lightning 2.6.2)

Leave a Reply

Your email address will not be published. Required fields are marked *